Advice The Home Improvement/Automation Thread

Valve1138

I eat my own poo with a spoon
Oct 19, 2004
40,118
14,724
823
South Harmon Institute of Technology
Marklar
₥60,275.54
Marklar
M60,276
For now, there is no UI for Zigbee locks, only ZWave. So it has to be done through Dev Tools.

BTW, just a general FYI, you will regularly use Developer Tools to understand states and how to call services to do things for automations.

Fuck that.

There's an app for our Schlage Sense. I'll stick with that.

I have yet to see any reason to dive into HA other than replacing the Tonesto SmartThings Homekit bridge.
 

Domon

enjoys a good porkin'
May 19, 2011
43,674
26,123
723
Marklar
₥43,115.69
Marklar
M43,116
For now, there is no UI for Zigbee locks, only ZWave. So it has to be done through Dev Tools.

BTW, just a general FYI, you will regularly use Developer Tools to understand states and how to call services to do things for automations.
this is what makes no sense to me. Im used to the "device driver" model in which once you get the device paired into the system, the software layer above that (lock manager) doesnt give a shit what the raw commands are, it just passed a "lock, unlock, whatever" command to the device driver (ZHA, device handler, whatever) and the device handler translates that into bytecode for whatever protocol is used (zigbee, wifi, zwave).
 

fly

Osharts 11
Oct 1, 2004
69,707
21,906
1,073
Marklar
₥46,624.23
Marklar
M46,624
Steam
mattressfish
Fuck that.

There's an app for our Schlage Sense. I'll stick with that.

I have yet to see any reason to dive into HA other than replacing the Tonesto SmartThings Homekit bridge.
My Kwikset is only managed via ZWave/Zigbee, which is fine by me. I've been on a mission to get rid of all 75 of my stupid smart apps. HA has gotten me pretty close.
 

fly

Osharts 11
Oct 1, 2004
69,707
21,906
1,073
Marklar
₥46,624.23
Marklar
M46,624
Steam
mattressfish
Yale YRD216ha

It is paired, but it seems ZHA doesnt know how to talk to it fully.
Are you sure? HA will create seperate entities for each thing. A sensor for the battery and a lock for the lock.

1602687448326.png

edit: This seems to indicate that Zigbee Yale locks work without issue.
 

fly

Osharts 11
Oct 1, 2004
69,707
21,906
1,073
Marklar
₥46,624.23
Marklar
M46,624
Steam
mattressfish

Domon

enjoys a good porkin'
May 19, 2011
43,674
26,123
723
Marklar
₥43,115.69
Marklar
M43,116
Also, any chance its a Control4 module (whatever that is)?

no, control4 is super high end proprietary smarthome stuff. Its plain old zigbee.
 

Domon

enjoys a good porkin'
May 19, 2011
43,674
26,123
723
Marklar
₥43,115.69
Marklar
M43,116
Are you sure? HA will create seperate entities for each thing. A sensor for the battery and a lock for the lock.

View attachment 12659

edit: This seems to indicate that Zigbee Yale locks work without issue.
that post (with no responses) is almost the exact problem i have. It only reports the most basic of functionality, which appears to not even include state. Extended state variables include "locked, unlocked, jammed, open, shut, contact" none of those report
 

fly

Osharts 11
Oct 1, 2004
69,707
21,906
1,073
Marklar
₥46,624.23
Marklar
M46,624
Steam
mattressfish
that post (with no responses) is almost the exact problem i have. It only reports the most basic of functionality, which appears to not even include state. Extended state variables include "locked, unlocked, jammed, open, shut, contact" none of those report
That guy is reporting exactly what I have in HA right now. Battery and lock state.
 

Domon

enjoys a good porkin'
May 19, 2011
43,674
26,123
723
Marklar
₥43,115.69
Marklar
M43,116
thats the problem with zigbee. It doesnt report in a standard way. My device apparently puts lock state in the extended category when the YD226 does not.
 

fly

Osharts 11
Oct 1, 2004
69,707
21,906
1,073
Marklar
₥46,624.23
Marklar
M46,624
Steam
mattressfish
thats the problem with zigbee. It doesnt report in a standard way. My device apparently puts lock state in the extended category when the YD226 does not.
Well that's dumb. If true, probably not HA's fault. Either way, are you *sure* you don't have another entity for the lock?
 

Domon

enjoys a good porkin'
May 19, 2011
43,674
26,123
723
Marklar
₥43,115.69
Marklar
M43,116
apparently a solution to this is to get a conbee II or some other separate zigbee gateway...... but if im gonna do that, ill just use the smartthings link
 

fly

Osharts 11
Oct 1, 2004
69,707
21,906
1,073
Marklar
₥46,624.23
Marklar
M46,624
Steam
mattressfish
apparently a solution to this is to get a conbee II or some other separate zigbee gateway...... but if im gonna do that, ill just use the smartthings link
So its your zigbee adapter? :wtf:

edit: I'm sure you've thought of this, but could it be that you need some mesh in between your usb stick and the door? Add more devices, then remove the lock and repair again.
 

Domon

enjoys a good porkin'
May 19, 2011
43,674
26,123
723
Marklar
₥43,115.69
Marklar
M43,116
So its your zigbee adapter? :wtf:

edit: I'm sure you've thought of this, but could it be that you need some mesh in between your usb stick and the door? Add more devices, then remove the lock and repair again.
those adapters translate zigbee into mqtt. So theyre just fundamentally different.